Apple Blocks Java 1.7.0_11 for Safari/Firefox plugin. Workaround (admin privilege needed)

UPDATE: JAVA 1.7.0_13 is now available from java’s website. Installing this should fix the...

Read More